読者です 読者をやめる 読者になる 読者になる

TensorFlow はじめから【日本語】

10年前の脳科学の学生がtensorflowをやってみた。英語のマニュアルしかないので日本語にまとめてみた。

【TensorFlow】Windowsへのpipインストール時のエラーについて

本家に説明がなかったため、スタックしそうになった件のtip。

 

TensorFlowインストールのために、先行してまずpythonをインストールした。

python3.6.xを、、、

 

そしたら、TensorFlowをインストールするときに、pythonでpipが弾かれる。。

下記のメッセージがコマンドプロンプトに出てくる

>Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow. 

 

stack overflowをみてたら、バージョンがうんたらくんたら書いてる。

とりあえず、インストール条件からちょっと見直し。python3.5.xでないとダメっぽい。

 

それでは!!と思いまた再度pythonを入れなおす。

 

結果、

>Could not find a version that satisfies the requirement tensorflow (from versions: ) No matching distribution found for tensorflow. 

 

かわらんやんけ!!!!!

えーっと、、とりあえずもいっかい下記を確認。。

<python - tensorflow not found in pip - Stack Overflow>

あ、32bitじゃあダメなのね。

hahahahaha,,,

 

ということで64bit版windowsに入れなおす。

f:id:tensorflow_japan:20170404172243j:plain

はい。

ちゃんとはいりました。

 

本家サイトには特にかいてないような。、、

AI界は32bit機に市民権はないようです。

 

(2017/4/4)